Después de un tiempo teniendo problemas con las actualizaciones de Windows Xp, ayer me puse ya seriamente a buscar el problema y por fin he encontrado la solución.

Las actualizaciones se me descargaban de windows update de forma normal, pero al instalarlas me daban error de que no se habian instalado correctamente, a pesar de tener windows original y todo aparentemente normal.

Después de intentar varias opciones y no conseguir ningun resultado, pues al final quien la sigue la consigue.

Miré con detalle el archivo WindowsUpdate.log, que se encuentra en la carpeta C:\WINDOWS.

lo podeis abrir tambien desde el menú inicio->ejecutar, escribir: %windir%\Windowsupdate.log

%windir% corresponde a la carpeta  C:\WINDOWS

Este archivo contiene información sobre las actualizaciones automáticas que se realizan en tu sistema. En el siguiente enlace se explica cómo leer este archivo:

http://support.microsoft.com/kb/902093/es

Como veis en la imagen el error lo podemos ver en la linea “FATAL:…” .Este error corresponde con el ejecutable wuauclt.exe.

Este ejecutable es el encargado de comprobar si hay actualizaciones para el sistema operativo.

(Ojo! existen programas malignos que usan el mismo nombre o similar para pasar desapercibidos en nuestro sistema)

Según Microsoft, este problema ocurre cuando se instala la última
versión del cliente Windows Update y luego se instala el SP3. Provoca que la biblioteca nueva Wups2.dll no quede
debidamente registrada. Al instalar el SP3 en esas condiciones, no
detecta la biblioteca Wups2.dll y registra la Wups.dll original del SP2
y SP3. Dado que los archivos registrados que corresponden a la nueva
Wups2.dll están perdidos, no se puede actualizar el sistema mediante
los servicios convencionales de actualización.

Para ello la solución está en abrir los servicios de windows y detener el servicio de las actualizaciones automáticas.

Inicio->Ejecutar->services.msc


y posteriormente registramos la biblioteca Wups2.dll:

Inicio->Ejecutar-> regsvr32 %windir%/system32/wups2.dll

o bien para x64:   regsvr32 %windir%/syswow64/wups2.dll

Despues volveis a activar el servicio de actualizaciones automáticas y problema resuelto, (aunque bueno, me abstengo en comentario de este tipo de errores).

 

Saludos